Caja Rural Open Banking - Partial Outage affecting Account Information
Incident Report for Tink providers Spain
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 15:25 UTC
Identified
We have identified the issue affecting account access, we are in contact with Caja Rural for further information.
We will update when a significant change to the situation occurs.
Posted Mar 27, 2024 - 12:21 UTC
This incident affected: Caja Rural.