Imagin Bank - Major outage

Incident Report for Tink providers Spain

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 10:35 CEST

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
- Affected users: [98]%
- Affected flow: refresh-manual
- Start Time: 21:00 CEST
- Provider name: es-imaginbank-password
- Bank side error: 409s responses
Posted Jun 07, 2026 - 22:18 CEST
This incident affected: Imagin.