Deutschebank - Major outage affecting Account Information

Incident Report for Tink providers Spain

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 09:53 UTC

Investigating

We are currently investigating an issue with Deutschebank.

Open Banking connection is unaffected.
Posted Jul 11, 2024 - 09:59 UTC
This incident affects: Deutsche Bank.