Imaginbank - Refreshes - Degraded performance

Incident Report for Tink providers Spain

Monitoring

Background refresh are still failing. We currently do not have a clear estimate when the service will recover, but we will update as soon as possible.
Posted Nov 07, 2025 - 15:20 CET

Investigating

We are currently investigating an issue with Imaginbank. The background refreshes are failing for a fraction of users.
Posted Sep 04, 2025 - 08:35 CEST
This incident affects: Imagin.