Kutxabank - Manual refreshes - Degraded performance
Incident Report for Tink providers Spain
Resolved
This incident has been resolved.
Posted Dec 12, 2024 - 08:26 UTC
Investigating
We are currently investigating an issue with Kutxabank. Open Banking connections are not affected.
Posted Dec 11, 2024 - 20:48 UTC
This incident affected: Kutxabank.