Caja Rural - Major Outage

Incident Report for Tink providers Spain

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 09:45 CEST

Investigating

We are currently investigating an issue with Caja Rural.

- Affected users: 100%
- Affected flow: Manual authentication flow
- Start Time: 21:15 CEST
- Bank side error: Bank side server error
- Provider name: es-cajarural-password
Posted Apr 09, 2026 - 21:37 CEST
This incident affected: Caja Rural.