Caixa Rural Les Coves - Major outage
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 16, 2024 - 11:12 UTC
Identified
We have identified the cause of the issue and are working on it.
Posted Apr 11, 2024 - 17:24 UTC
This incident affected: Caixa Rural Les Coves.