Ruralvia - Partial Outage
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Mar 05, 2024 - 07:50 UTC
Investigating
We are currently investigating an issue with Ruralvia.
Posted Mar 04, 2024 - 22:09 UTC
This incident affected: Ruralvia.