Banco Sabadell - Major outage affecting Account Information.
Incident Report for Tink providers Spain
Update
We are continuing to work on a fix for this issue.
Posted May 28, 2024 - 08:44 UTC
Identified
We have identified the issue and are in contact with Banco Sabadell for further information.
We will update when a significant change to the situation occurs.

Open Banking connection us unaffected.
Posted May 28, 2024 - 07:51 UTC
This incident affects: Banco Sabadell.