Imaginbank - AIS Major outage

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Nov 18, 2025 - 16:59 CET

Identified

- Affected users: 90 %
- Affected flow: Manual authentication, Refresh manual flows
- Start Time: 18/11/2025 12:45 CET
- Bank side error: 500 error on login endpoint.
- Provider name: es-imaginbank-password
Posted Nov 18, 2025 - 14:14 CET
This incident affected: Imagin.