BBVA - Major Outage affecting Account Information Services

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 17, 2025 - 15:34 UTC

Investigating

We have identified the cause of the issue and are working on it.

Open Banking connection is unaffected.
Posted Mar 10, 2025 - 21:46 UTC
This incident affected: BBVA.