BBVA - Major Outage affecting Account Information
Incident Report for Tink providers Spain
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 08:00 UTC
Identified
We have identified the issue and are in contact with BBVA for further information.
This issue does not affect Open Banking
We will update when a significant change to the situation occurs.
Posted Apr 07, 2024 - 18:45 UTC
This incident affected: BBVA.