Caixa Bank - Open Banking - Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 21, 2025 - 07:28 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Mar 20, 2025 - 17:32 UTC
This incident affected: CaixaBank.