Banco Sabadell - Partial Outage

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Oct 05, 2025 - 20:32 CEST

Investigating

We are currently investigating an issue with Banco Sabadell.
Posted Oct 05, 2025 - 04:38 CEST
This incident affected: Banco Sabadell.