Imagin OB - Degraded performance affecting Manual authentication
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 05, 2024 - 13:40 UTC
Identified
We have identified the issue and are in contact with Imagin OB for further information. Non-open banking connections are unaffected.
We will update when a significant change to the situation occurs.
Posted Jun 20, 2024 - 13:44 UTC
This incident affected: Imagin.