Banco Santander - Degraded performance

Incident Report for Tink providers Spain

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 14:42 CEST

Identified

We have identified an issue and are currently working on a fix.
- Affected users: 5-10%
- Affected flow: All flows
- Start Time: 13:20 CEST
- Provider name: es-bancosantander-password
Posted Apr 14, 2026 - 17:01 CEST
This incident affected: Banco Santander.