ING - Major Outage - All services
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Mar 18, 2024 - 15:22 UTC
Identified
We have identified the issue and are in contact with ING for further information.
An update will be posted when a significant change to the situation occurs.
Posted Mar 18, 2024 - 10:28 UTC
This incident affected: ING.