EVO Banco - Issue with Account Information - Major outage
Incident Report for Tink providers Spain
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 15:09 UTC
Update
We are continuing to investigate the issue with credit cards.
Posted Feb 20, 2023 - 10:32 UTC
Update
We're still working on a solution.
Posted Jan 11, 2023 - 08:52 UTC
Update
We are now able to gather all account information except credit cards. We are working on restoring full functionality.
Posted Dec 19, 2022 - 10:07 UTC
Investigating
We are currently investigating an issue with EVO Banco.
Posted Dec 01, 2022 - 10:41 UTC
This incident affected: EVO Banco.