Deutsche Bank - Degraded Performance affecting Account Information
Incident Report for Tink providers Spain
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 07:58 UTC
Identified
We have identified the issue and are in contact with Deutsche Bank for further information.
This issue occurs during authentication but not affecting Open Banking
We will update when a significant change to the situation occurs.
Posted Apr 07, 2024 - 18:25 UTC
This incident affected: Deutsche Bank.