OpenBank - Degraded performance
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Apr 02, 2024 - 12:13 UTC
Investigating
We are currently investigating an issue with Openbank.
Posted Mar 31, 2024 - 20:45 UTC
This incident affected: Openbank.