Cajasur, Kutxabank Outage

Incident Report for Tink providers Spain

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 06:19 UTC

Investigating

Investigating - Tink automatic monitoring service has detected a service outage. Affected flow(s): manual refresh.
Open banking connection is unaffected.
Posted Jun 21, 2025 - 23:41 UTC
This incident affected: Cajasur and Kutxabank.