Openbank - Major outage affecting Account Information
Incident Report for Tink providers Spain
Update
We have identified the cause of the issue and are working on it.
Posted Apr 15, 2024 - 19:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 15, 2024 - 19:44 UTC
Identified
We have identified an issue with Openbank from 10:30 CEST.
We will update when a significant change to the situation occurs.

Open Banking connection is unaffected.
Posted Apr 15, 2024 - 10:23 UTC
This incident affects: Openbank.