Ibercaja - Major outage affecting Account Information
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Mar 12, 2024 - 10:19 UTC
Identified
We have identified the issue and are in contact with Ibercaja for further information.
Open banking connections are not affected.
We will update when a significant change to the situation occurs.
Posted Mar 12, 2024 - 07:24 UTC
This incident affected: IberCaja.