Imagin Bank unplanned maintenance
Incident Report for Tink providers Spain
Resolved
The unplanned maintenance has been completed since 10:00 CEST.
We apologize for the inconvenience.
Posted Apr 13, 2024 - 13:39 UTC
Investigating
Imagin Bank is currently under unplanned maintenance starting on 2024-04-12 from 23:58 CEST for 10 hours. During this time, all services will not be available.

Open Banking connections are unaffected.
Posted Apr 12, 2024 - 22:16 UTC
This incident affected: Imagin.