IberCaja - Degraded performance
Incident Report for Tink providers Spain
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 07:33 UTC
Update
This issue is still in progress. We are in contact with IberCaja to obtain further information.
Posted Mar 12, 2024 - 13:24 UTC
Identified
We have identified the issue and are in contact with IberCaja for further information.

This incident affects Continuous Access Refreshes performance.

Open banking connections are not affected.

We will update when a significant change to the situation occurs.
Posted Dec 20, 2023 - 12:18 UTC
This incident affected: IberCaja.