Unicaja - Major Outage

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted May 19, 2025 - 11:33 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted May 19, 2025 - 10:37 UTC
This incident affected: Unicaja.