Laboral Kutxa Open Banking - Partial outage
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Nov 21, 2022 - 10:18 UTC
Identified
We have identified the cause of the issue and are working on it.
Posted Nov 18, 2022 - 10:56 UTC
This incident affected: Laboral Kutxa.