BBVA - Open Banking - Major outage affecting Account Information

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 25, 2025 - 10:15 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Mar 25, 2025 - 06:16 UTC
This incident affected: BBVA.