Targobank authentication issues
Incident Report for Tink providers Spain
Resolved
Unfortunately, the underlying cause behind this outage has not been resolved and we have decided to disable this provider until further notice.
Posted Jul 25, 2022 - 08:42 UTC
Investigating
We are currently investigating an issue with Targobank.
Posted Apr 27, 2022 - 11:16 UTC