IberCaja - Partial outage
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Nov 22, 2022 - 12:16 UTC
Identified
We have identified the cause of the issue and are working on it.
Posted Nov 21, 2022 - 09:37 UTC
Investigating
We are currently investigating an issue with IberCaja
Posted Nov 21, 2022 - 09:13 UTC
This incident affected: IberCaja.