EVO banco Background refresh issue
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Jul 06, 2022 - 10:35 UTC
Investigating
We are currently investigating an issue with EVO banco.
Posted May 12, 2022 - 08:31 UTC
This incident affected: EVO Banco.