Laboral Kutxa Major Outage
Incident Report for Tink providers Spain
Update
We are currently investigating an issue with Laboral Kutxa.
Posted Mar 12, 2024 - 20:08 UTC
Investigating
We are currently investigating an issue with Laboral Kutxa.
Posted Mar 12, 2024 - 16:02 UTC
This incident affects: Laboral Kutxa.