Cetelem - Major outage

Incident Report for Tink providers Spain

Update

We are continuing to work on a fix for this issue.
Posted Apr 08, 2025 - 09:53 UTC

Identified

We have identified the cause of an issue impacting Account Information and are working on it. Open Banking connection is unaffected.
Posted Apr 12, 2024 - 14:03 UTC
This incident affects: Cetelem.