Unicaja - Major outage affecting Account Information
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Nov 11, 2024 - 12:16 UTC
Identified
We have identified the issue and we will update when a significant change to the situation occurs.
Posted Nov 11, 2024 - 08:31 UTC
This incident affected: Unicaja.