Bnext - Major Outage
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 06, 2024 - 15:41 UTC
Investigating
We are currently investigating an issue with Bnext.
Posted Sep 17, 2024 - 05:11 UTC
This incident affected: Bnext.