Imaginbank - Major Outage AIS and PIS

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Nov 18, 2025 - 16:57 CET

Investigating

We are currently investigating an issue with Imaginbank.

- Affected users: 100 %
- Affected flow: Manual authentication, Manual refresh, Payment Initiation flows
- Start Time: 18/11/2025 14:38 CET
- Bank side error: authentication endpoint
- Provider name: es-redsys-imaginbank-ob
Posted Nov 18, 2025 - 15:55 CET
This incident affected: Imagin.