Banco Cooperativo Open Banking - Major Outage
Incident Report for Tink providers Spain
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Dec 05, 2024 - 13:31 UTC
Investigating
We are currently investigating an issue with Banco Cooperativo Open Banking.
Posted Jul 10, 2024 - 09:25 UTC
This incident affected: Banco Cooperativo.