Abanca - Partial Outage

Incident Report for Tink providers Spain

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Apr 02, 2025 - 07:01 UTC

Investigating

We are currently investigating an issue with Abanca that affects Payment Initiation.
Posted Apr 01, 2025 - 21:13 UTC
This incident affected: Abanca.